Android

Android 14 will prevent the installation of out-of-date applications

Posted on

Android 14 will begin completely blocking the installation of apps that target out-of-date versions of Android to lower the risk of malware.

The guidelines for the Google Play Store have made sure that Android app developers update their apps to use the most recent Android features and safety measures for years. The guidelines were updated just this month to say that newly listed Play Store apps must at least target Android 12.

Know how it will stop installing out-of-date applications

  • Up until this point, these minimum API level requirements only applied to Google Play Store-targeted apps. A developer can ask users to manually sideload the APK file if they wish to create an application for an earlier version.
  • Android 14 is set to tighten API requirements, according to a newly published code change, completely preventing the installation of out-of-date applications. Users would be prevented from sideloading particular APK files due to this change, as would app stores.

At first, Android 14 devices will only block applications that target older versions of Android. However, Google intends to “progressively ramp [it] up” to raise the threshold to Android 6.0 (Marshmallow) over time. However, it will likely still be up to each device manufacturer to determine whether or not to enable the threshold for outdated apps.

If the minimum installable SDK version enforcement is enabled, block the install of apps using a lower target SDK version than required. This helps improve security and privacy as malware can target older SDK versions to avoid enforcement of new API behavior.

Google wants to stop malware apps from spreading on Android by blocking these out-of-date applications. The person who made the change says that malware apps have deliberately targeted older versions of Android to get around security features that only apply to newer apps.

Lastly, you will still be able to use a new flag in a command shell to install an outdated application for any reason. It is less likely that someone will accidentally install malware because of the additional steps required.

Leave a Reply

Your email address will not be published. Required fields are marked *

Most Popular

Exit mobile version